+++ /dev/null
-ian@treetowl.11407:1508122283
\ No newline at end of file
# assign classes to hosts based on their hostname
-# NOTE:
-# 51-multi-boot should have something like this
-# for transient host configs which are not saved in
-# git (and make it executable):
-
-# if [[ ! -e /a/bin/fai/fai-wrapper ]]; then
-# case $HOSTNAME in
-# frodo) echo STABLE ;;
-# esac
-# fi
-
-
# do not use this if a menu will be presented
[ "$flag_menu" ] && exit 0
# ian: note everything after the grub package should be refactored into
# a new class.
PACKAGES install GRUB_PC
-grub-pc cryptsetup btrfs-tools sudo bridge-utils netcat-openbsd
+grub-pc cryptsetup btrfs-tools sudo bridge-utils netcat-openbsd resolvconf
PACKAGES install GRUB_EFI
-grub-efi cryptsetup btrfs-tools sudo bridge-utils netcat-openbsd
+grub-efi cryptsetup btrfs-tools sudo bridge-utils netcat-openbsd resolvconf
+
+
+#resolvconf because dpkg-reconfigure on it has this message in flidas:
+# Reboot recommended
+
+# Suppliers of name server information such as local caching name servers and interface configurers are expected to supply name server information to the resolvconf program. However, although
+# installation of the resolvconf package triggers them to supply their information, some of them fail to do so.
+
+# This bug would lead to loss of valid name server information on installation of the resolvconf package if the following workaround were not adopted: resolvconf includes the full contents of
+# the pre-installation /etc/resolv.conf in its database until reboot. This has the drawback that name server information is retained even if the associated interface is later deconfigured.
+# (This incorrect behavior is judged to be less harmful than the alternative of losing valid information.)
+
+# Until the bug in question is fixed and the workaround removed, the only way to ensure that resolvconf has fully correct name server information after the resolvconf package has been
+# installed on a running system is to reboot the system.
+
PACKAGES install LVM
lvm2
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
-x="$(readlink -f "$BASH_SOURCE")"; source "${x%/*}/bash-trace"
+set -eE -o pipefail
+trap 'echo "$0:$LINENO:error: \"$BASH_COMMAND\" returned $?" >&2' ERR
+
pmirror() {
# background: upgrading all packages is not recommended because it
option 'interface' 'lan'
option 'target' '10.173.0.0'
option 'netmask' '255.255.0.0'
- option 'gateway' '192.168.1.2'
+ option 'gateway' '192.168.1.3'
EOF
v cedit /etc/config/firewall <<'EOF' || firewall_restart=true
config redirect
option src wan
- option src_dport 1194
+ option src_dport 1196
option dest lan
option dest_ip 192.168.1.2
option proto udp
config rule
option src wan
option target ACCEPT
- option dest_port 1194
+ option dest_port 1196
option proto udp